All repair work has been completed and alarms have cleared. Teams will be hands off the repairs site within 30 minutes.
Posted Jul 28, 2025 - 15:57 EDT
Update
Crews are finalizing repairs at the damage location. Currently monitoring restoration of remaining circuits.
Posted Jul 28, 2025 - 14:44 EDT
Update
Repair work is still in progress. VNET network operations team is seeing services restore in affected areas.
Posted Jul 28, 2025 - 13:34 EDT
Update
Crews are currently splicing new fibers at the location of the damage. Services in many affected areas will begin to restore shortly.
Posted Jul 28, 2025 - 12:36 EDT
Update
Crews are currently at the site of the damage setting up to install new splice cases and cabling. No estimated time of repair provided.
Posted Jul 28, 2025 - 10:43 EDT
Identified
The fiber cut has been located. Damage appears to have been caused by 3rd party contractors working in the area. Splice and Construction Crews have been dispatched to the site of the damage. No estimated time of repair provided.
Posted Jul 28, 2025 - 09:46 EDT
Investigating
We are currently investigating a possible fiber cut affecting internet and voice customers in SW Erie, Millcreek, and Summit. Crews have been dispatched to investigate.
Posted Jul 28, 2025 - 09:23 EDT
This incident affected: VNET Fiber - Residential (FTTH - Internet, FTTH - Voice) and VNET Fiber - Commercial (Commercial Internet).